Back to Results Report a Data Problem

Moorestown Ecumenical Neighborhood Development (MEND)

Agency: MEND - Moorestown Ecumenical Neighborhood Development
Service Description:

Moorestown Ecumencial Neighborhood Development (MEND) is a community housing development program that provides low and moderate income rental housing for families, senior citizens, and the disabled. (A limited stock of housing for the disabled.) Housing is developed and furbished to meet the everyday needs of the clients. Amenities include:

- Modern appliances
- On-site laundry
- Handicap accessibility (for senior citizens and disabled)
- Barrier-free entry ways (for senior citizens and disabled)

Fees:

Successful applicants will need to pay for a credit report and any necessary background checks. Please call for additional fee information.

Eligibility:

Low and moderate income families, senior citizens (ages 62 and older), and individuals with disabilities residing in Burlington or Camden County. Income must be below 80% of the median.

Application Instructions:

Please complete the pre-application, which is available through the website. Upon submittal, applicants being considered for approval will be directed to a webpage of links with further downloadable applications. Otherwise, all other applicants will be directed to another webpage with contact information to call and speak with a MEND representative.

Required Documents:

  • proof of household income
  • Last Update: October 23, 2015

    Mapit
    Address:

    99 E Second St

    Moorestown, NJ 08057

    Web Address:

    http://www.mendinc.org

    Areas Served:

    Burlington and Camden Counties

    Business Hours:

    Regular Hours:
    Mon - Fri 8:30am - 5:00pm

    Summer Hours (Memorial Day to Labor Day):
    Mon - Thu 8:30am - 5:00pm
    Fri 8:30am - 1:00pm

    Telephones: types, numbers and hours
    Type Number Details
    Main Phone (856) 722-7070
    Fax (856) 722-7577 Fax number for service

    Email:

    Features:

    Referral Required

  • No referral required